summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:40:57 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit3f174923c7da9ec2805672f933e20729f8ed1e7c (patch)
treef57872e0bb8429465b2fd2c3f20981de94f4b627 /meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
parent38682b461c31c252e2b3647d574727149a7423d4 (diff)
downloadmeta-cloud-services-3f174923c7da9ec2805672f933e20729f8ed1e7c.tar.gz
python-oslo*: convert to 'git' and uprev
These python-oslo* recipes did not previously use git so switching them to make future uprevs simpler. While we are at it uprev to the version required for the liberty release. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.config_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.config_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
new file mode 100644
index 0000000..abd3269
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "API supporting parsing command line arguments and .ini style configuration files."
2HOMEPAGE = "https://pypi.python.org/pypi/oslo.config/2.6.0"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7PV = "2.6.0+git${SRCPV}"
8SRCREV = "ee2bab65e9a2f38bb915f106a4da1520e4b5060c"
9
10SRCNAME = "oslo.config"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools rmargparse
16
17DEPENDS += " \
18 python-pbr \
19 python-pip \
20 "
21
22RDEPENDS_${PN} += " \
23 python-pbr \
24 python-netaddr \
25 python-six \
26 python-stevedore \
27 "