summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:22 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit27dca14941e32ec7897a6a9bfa28908f849a0651 (patch)
tree2d7f0c6ab6d73153d4667275624fd71e2615d4bb /meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb
parentd0b24c0e256ef93079c47384d0c4a297b73df57e (diff)
downloadmeta-cloud-services-27dca14941e32ec7897a6a9bfa28908f849a0651.tar.gz
python-oslo.cache: initial version
This package provides an oslo.config enabled dogpile.cache. This package is required by heat. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb
new file mode 100644
index 0000000..1886e78
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.cache_git.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "An oslo.config enabled dogpile.cache"
2HOMEPAGE = "https://github.com/openstack/oslo.cache"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "0.7.0+git${SRCPV}"
8SRCREV = "24f10af201da9264ba3db6eb2e8fcf583008d6b6"
9
10SRCNAME = "oslo.cache"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python-babel \
27 python-dogpile.cache \
28 python-six \
29 python-oslo.config \
30 python-oslo.i18n \
31 python-oslo.log \
32 python-oslo.utils \
33 python-memcached \
34 python-pymongo \
35 "