summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:02 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit03e3e1ec39be29e6772e74a8dc25d8164b5ca159 (patch)
tree3209309ccde45136248ae441a6c5fbf6656cd84d /meta-openstack/recipes-devtools/python/python-os-brick_git.bb
parentf940b9d81d1f3d20f48da2a486ebfd334be0209a (diff)
downloadmeta-cloud-services-03e3e1ec39be29e6772e74a8dc25d8164b5ca159.tar.gz
python-os-brick: initial version
This package provides an OpenStack Cinder brick library for managing local volume attaches. This package is required by nova and cinder. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-os-brick_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-brick_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-brick_git.bb b/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
new file mode 100644
index 0000000..cbfc8ab
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "OpenStack Cinder brick library for managing local volume attaches"
2HOMEPAGE = "https://github.com/openstack/os-brick"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-brick.git;branch=master \
9 "
10
11PV = "0.5.0+git${SRCPV}"
12SRCREV = "5ac54d4e0c89daba1be80702ee4060a538c08754"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17FILES_${PN} += "${datadir}/etc/*"
18
19DEPENDS += " \
20 python-pbr \
21 "
22
23RDEPENDS_${PN} += " \
24 python-pbr \
25 "