summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:12 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitb45ce183ceaf30592521a84fb5cd06c827343e82 (patch)
tree424995ce94db2681cd738de29ac6e32e20a7a4c1 /meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb
parentb2687efd47424be847e45ef1bd21ce39e2419a85 (diff)
downloadmeta-cloud-services-b45ce183ceaf30592521a84fb5cd06c827343e82.tar.gz
python-ordereddict: initial version
This package provides a drop-in substitute for Py2.7's new collections.OrderedDict that works in Python 2.4-2.6. This package is required by oslo.middleware. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb b/meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb
new file mode 100644
index 0000000..db8afa3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-ordereddict_1.1.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A drop-in substitute for Py2.7's new collections.OrderedDict that works in Python 2.4-2.6."
2HOMEPAGE = "https://pypi.python.org/pypi/ordereddict"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7f0267460024072a9bbf135ee87a41b8"
6
7
8SRCNAME = "ordereddict"
9SRC_URI = "http://pypi.python.org/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "a0ed854ee442051b249bfad0f638bbec"
12SRC_URI[sha256sum] = "1c35b4ac206cef2d24816c89f89cf289dd3d38cf7c449bb3fab7bf6d43f01b1f"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18# DEPENDS_default: python-pip
19
20DEPENDS += " \
21 python-pip \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python-pip \
27 "