summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-10-07 17:38:45 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-10-13 11:32:41 -0400
commit28a56b809d39fde53187e3247fc88220ac19017b (patch)
treec30112b5281e567135a547a98ceede24d2b43017 /meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb
parentb1654d0f0f011c3d5ea82b5fde5a9f953db7cac3 (diff)
downloadmeta-cloud-services-28a56b809d39fde53187e3247fc88220ac19017b.tar.gz
openstackcclient: New version and updated dependencies
Updated to the newest version in kilo, and added dependencies, The dependency on cliff-tablib fixes this error: > openstack token issue ERROR: openstackclient.shell Exception raised: cliff-tablib>=1.0 Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb b/meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb
new file mode 100644
index 0000000..a585b68
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-openstackclient_1.0.4.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "OpenStack Command-line Client"
2HOMEPAGE = "https://github.com/openstack/python-openstackclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRCNAME = "python-openstackclient"
8
9SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "595c9be3ae2f967f7dd5f33753137377"
12SRC_URI[sha256sum] = "d39a2e6cf98d409f8545b9d3a207eb8cbf3b2fc5ea17b0f8d9bed52326ca9f49"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18DEPENDS += "\
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += "\
23 python-babel \
24 python-cinderclient \
25 python-cliff \
26 python-cliff-tablib \
27 python-glanceclient \
28 python-keystoneclient \
29 python-neutronclient \
30 python-novaclient \
31 python-oslo.config \
32 python-oslo.i18n \
33 python-oslo.serialization \
34 python-oslo.utils \
35 python-pbr \
36 python-requests \
37 python-six \
38 python-stevedore \
39 "