summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-11-06 15:10:37 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:36 -0500
commitfee9116d124b7c593aa9ffdeda9b8f71ba1fcfea (patch)
treee511032a8d0c86e3a567ca148585b24fa6fc0a5d /meta-openstack/recipes-devtools/python/python-novaclient_git.bb
parentd157ee906088900566687d145a455b52b6de1b51 (diff)
downloadmeta-cloud-services-fee9116d124b7c593aa9ffdeda9b8f71ba1fcfea.tar.gz
python-novaclient: uprev and move to git based build
To meet havana requirements, we must uprev to the latest novaclient. At the same time, we switch to a SRCREV based git build. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-novaclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
new file mode 100644
index 0000000..06fd848
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Client library for OpenStack Compute API"
2HOMEPAGE = "https://github.com/openstack/python-novaclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7cdb54622cacc9bc9b2883091e6dd669"
6DEPENDS = "python-setuptools-git"
7
8PR = "r0"
9
10SRC_URI = "https://pypi.python.org/packages/source/p/${PN}/${PN}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "e1079ade7e1956c8ea0613ca7910ab54"
13SRC_URI[sha256sum] = "f48c9c159ea8efd617f0379d1df060ea53f40f40e29ebe733464779267a314e6"
14
15inherit setuptools
16
17RDEPENDS_${PN} += "python-iso8601 \
18 python-prettytable \
19 python-requests \
20 python-simplejson \
21 "