summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-13 10:43:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-16 00:24:40 -0400
commit7af8f00fc7ff4f3301744c568c9b503b05aafbeb (patch)
treea991e21f593525c26e5da1946ce1b93d9145ef70 /meta-openstack/recipes-devtools/python/python-novaclient_git.bb
parent3d1957e1be2d2eee52cb686e49dba1d013896d12 (diff)
downloadmeta-cloud-services-7af8f00fc7ff4f3301744c568c9b503b05aafbeb.tar.gz
novaclient: fix path to test certificate
Novaclient contains a test that fails because it can't find the path to the test certficate. This is because the test is based off of running the test from the base of the source tree. This fix changes the path to look for the certificate from a relative path to the absolute path allowing the test to be ran from any directory. Signed-off-by: Keith Holman <Keith.Holman@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-novaclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
index 9d114d2..3bb3aac 100644
--- a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
@@ -9,6 +9,7 @@ PR = "r0"
9SRC_URI = "\ 9SRC_URI = "\
10 git://github.com/openstack/python-novaclient.git;branch=master \ 10 git://github.com/openstack/python-novaclient.git;branch=master \
11 file://fix_novaclient_memory_leak.patch \ 11 file://fix_novaclient_memory_leak.patch \
12 file://novaclient-specify-full-path-to-test-certificate.patch \
12 " 13 "
13 14
14PV="2.16.0+git${SRCPV}" 15PV="2.16.0+git${SRCPV}"
@@ -36,6 +37,9 @@ PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-
36do_install_append() { 37do_install_append() {
37 install -d ${D}/${sysconfdir}/bash_completion.d 38 install -d ${D}/${sysconfdir}/bash_completion.d
38 install -m 664 ${S}/tools/nova.bash_completion ${D}/${sysconfdir}/bash_completion.d 39 install -m 664 ${S}/tools/nova.bash_completion ${D}/${sysconfdir}/bash_completion.d
40
41 sed -e "s:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g" \
42 -i ${D}/${PYTHON_SITEPACKAGES_DIR}/novaclient/tests/v1_1/test_servers.py
39} 43}
40 44
41PACKAGES =+ "${BPN}-bash-completion" 45PACKAGES =+ "${BPN}-bash-completion"