summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
commit3b9fa62452c636c49cc1bd19436e37882c76b88c (patch)
tree3fc5e422f733d9e037f387638a459eeaeecbab61 /meta-openstack/recipes-devtools/python/python-novaclient_git.bb
parenta8dbfb290b485d41da1bea5dd37907db684d86fc (diff)
downloadmeta-cloud-services-3b9fa62452c636c49cc1bd19436e37882c76b88c.tar.gz
clients: add bash-completion support
Package and enable the bash completion suppor that comes with the various client packages. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-novaclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient_git.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
index 7ac9b34..ff81924 100644
--- a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
@@ -3,7 +3,6 @@ HOMEPAGE = "https://github.com/openstack/python-novaclient"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7cdb54622cacc9bc9b2883091e6dd669" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=7cdb54622cacc9bc9b2883091e6dd669"
6DEPENDS = "python-setuptools-git"
7 6
8PR = "r0" 7PR = "r0"
9 8
@@ -18,6 +17,7 @@ S = "${WORKDIR}/git"
18 17
19inherit setuptools 18inherit setuptools
20 19
20DEPENDS = "python-setuptools-git"
21DEPENDS += " \ 21DEPENDS += " \
22 python-pip \ 22 python-pip \
23 python-pbr \ 23 python-pbr \
@@ -29,3 +29,14 @@ RDEPENDS_${PN} += "python-iso8601 \
29 python-simplejson \ 29 python-simplejson \
30 python-pbr \ 30 python-pbr \
31 " 31 "
32
33PACKAGECONFIG ?= "bash-completion"
34PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
35
36do_install_append() {
37 install -d ${D}/${sysconfdir}/bash_completion.d
38 install -m 664 ${S}/tools/nova.bash_completion ${D}/${sysconfdir}/bash_completion.d
39}
40
41PACKAGES =+ "${BPN}-bash-completion"
42FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"