summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-04 00:26:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-04 00:26:04 -0400
commit6806482a7ba6f020b0cff44b2b797eede2b702af (patch)
treecfc7df9ca2c8e110ebe8a5b94c782c691b8f5878 /meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb
parentce230a25691dab2c8f3c7b9fc7ef37d548f8f90b (diff)
downloadmeta-cloud-services-6806482a7ba6f020b0cff44b2b797eede2b702af.tar.gz
python-nova: unify controller and compute recipes
The split of compute and controller is no longer necesary, since configuration inheritance is done with overriding layers, not split recipes. This simplifies the build, and packaging of the recipe. Good riddance. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb87
1 files changed, 0 insertions, 87 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb
deleted file mode 100644
index c99a890..0000000
--- a/meta-openstack/recipes-devtools/python/python-nova-controller_2013.1.3.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1include python-nova.inc
2
3PR = "r0"
4
5FILESEXTRAPATHS := "${THISDIR}/${PYTHON_PN}"
6
7SRC_URI += "file://nova-all \
8 file://nova-consoleauth \
9 file://nova-novncproxy \
10 file://nova.conf \
11 file://openrc \
12 "
13
14inherit hosts update-rc.d
15
16PACKAGES = "${PN} ${PN}-dbg ${SRCNAME}-controller-misc ${SRCNAME}-controller"
17PACKAGES += " ${SRCNAME}-consoleauth"
18PACKAGES += " ${SRCNAME}-novncproxy"
19
20do_install_append() {
21 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
22 install -d ${D}${sysconfdir}/init.d
23 install -m 0755 ${WORKDIR}/nova-all ${D}${sysconfdir}/init.d/nova-all
24 install -m 0755 ${WORKDIR}/nova-consoleauth ${D}${sysconfdir}/init.d/nova-consoleauth
25 install -m 0755 ${WORKDIR}/nova-novncproxy ${D}${sysconfdir}/init.d/nova-novncproxy
26 fi
27}
28
29pkg_postinst_${SRCNAME}-controller () {
30 if [ "x$D" != "x" ]; then
31 exit 1
32 fi
33
34 # This is to make sure postgres is configured and running
35 if ! pidof postmaster > /dev/null; then
36 sudo -u postgres initdb -D /etc/postgresql/
37 /etc/init.d/postgresql start
38 sleep 0.2
39 sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
40 fi
41
42 sudo -u postgres createdb nova
43 nova-manage db sync
44}
45
46
47#FILES_${SRCNAME}-controller = "${files_${SRCNAME}-controller}"
48#
49# If the compute is built, so we package it out of the way
50
51#FILES_${SRCNAME}-controller-misc = "${files_${SRCNAME}-compute}
52#${files_${SRCNAME}-common} ${files_${PYTHON_PN}}"
53
54FILES_${SRCNAME}-controller = " \
55 ${bindir} \
56 ${sysconfdir}/${SRCNAME}/* \
57 ${sysconfdir}/init.d/nova-all \
58"
59
60FILES_${SRCNAME}-consoleauth = " \
61 ${sysconfdir}/init.d/nova-consoleauth \
62"
63FILES_${SRCNAME}-novncproxy = " \
64 ${sysconfdir}/init.d/nova-novncproxy \
65"
66
67FILES_${SRCNAME}-controller-misc = " \
68 ${bindir}/nova-compute \
69 ${sysconfdir}/init.d/nova-compute \
70 ${bindir}/nova-manage \
71 ${bindir}/nova-rootwrap \
72 ${sysconfdir}/sudoers.d \
73 ${libdir}"
74
75FILES_${PN} = " \
76 ${libdir}/python*/site-packages"
77
78RDEPENDS_${SRCNAME}-controller = "${PYTHON_PN} ${SRCNAME}-common ${SRCNAME}-consoleauth \
79 ${SRCNAME}-novncproxy \
80 postgresql postgresql-client python-psycopg2"
81
82RCONFLICTS_${SRCNAME}-controller = "${SRCNAME}-compute"
83
84INITSCRIPT_PACKAGES = "${SRCNAME}-controller ${SRCNAME}-consoleauth ${SRCNAME}-novncproxy"
85INITSCRIPT_NAME_${SRCNAME}-controller = "nova-all"
86INITSCRIPT_NAME_${SRCNAME}-consoleauth = "nova-consoleauth"
87INITSCRIPT_NAME_${SRCNAME}-novncproxy = "nova-novncproxy"