summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-neutron_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-04-09 10:58:23 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-15 19:48:37 -0400
commitfba2860d0e50a5fe61b47cb9c9234725821b1d0b (patch)
tree2159643482c6b209db969354550d6f415b6977d5 /meta-openstack/recipes-devtools/python/python-neutron_git.bb
parent509875734bb5e935436d2b09192e8b5e4c1500cb (diff)
downloadmeta-cloud-services-fba2860d0e50a5fe61b47cb9c9234725821b1d0b.tar.gz
python-neutron: openvswitch plugin read config files
Currently the openvswitch plugin doesn't read any config files so we are unable to configure it properly. Have the init script pass in the config files we are already installing. The config needs local_ip set otherwise it will fail to run. We can't just tack rabbit_host on the end of the conf file as it is in the wrong section, so change this to a substitution. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-neutron_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 1621923..9b291df 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -35,7 +35,7 @@ do_install_append() {
35 sed -e "s:^# core_plugin.*:core_plugin = neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2:g" \ 35 sed -e "s:^# core_plugin.*:core_plugin = neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2:g" \
36 -i ${WORKDIR}/neutron.conf 36 -i ${WORKDIR}/neutron.conf
37 37
38 echo "rabbit_host = ${CONTROLLER_IP}" >> ${WORKDIR}/neutron.conf 38 sed -e "s:^# rabbit_host =.*:rabbit_host = ${CONTROLLER_IP}:" -i ${WORKDIR}/neutron.conf
39 39
40 for file in ovs_neutron_plugin.ini linuxbridge_conf.ini 40 for file in ovs_neutron_plugin.ini linuxbridge_conf.ini
41 do 41 do
@@ -56,7 +56,7 @@ do_install_append() {
56 install -m 600 ${S}/etc/policy.json ${NEUTRON_CONF_DIR}/ 56 install -m 600 ${S}/etc/policy.json ${NEUTRON_CONF_DIR}/
57 57
58 PLUGIN=openvswitch 58 PLUGIN=openvswitch
59 ARGS="" 59 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/plugins/openvswitch/ovs_neutron_plugin.ini"
60 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 60 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
61 install -d ${D}${sysconfdir}/init.d 61 install -d ${D}${sysconfdir}/init.d
62 sed "s:@plugin@:/etc/neutron/plugins/$PLUGIN/ovs_neutron_plugin.ini:" \ 62 sed "s:@plugin@:/etc/neutron/plugins/$PLUGIN/ovs_neutron_plugin.ini:" \