summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-neutron_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:13 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:24:31 -0400
commite617d0205fc566ef70b61a75c484d78c540ef791 (patch)
treec5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-neutron_git.bb
parent2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff)
downloadmeta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz
Readjust the start level of openstack components
Currently all the openstack components have default start level of 20. There are other services such as glusterfs, rabbbitmq, database... are also starting at the same start level. On some platform, this can cause racing condition between services which in turn causes some of openstack components not started. By adjusting the openstack components start level to higher will ensure that system services start in the determistic way. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-neutron_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 4aa974e..4e3c1b8 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -18,7 +18,7 @@ PV="2013.2.2+git${SRCPV}"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit setuptools update-rc.d identity hosts 21inherit setuptools update-rc.d identity hosts default_configs
22 22
23do_install_append() { 23do_install_append() {
24 TEMPLATE_CONF_DIR=${S}${sysconfdir}/ 24 TEMPLATE_CONF_DIR=${S}${sysconfdir}/
@@ -204,5 +204,8 @@ RRECOMMENDS_${SRCNAME}-server = "${SRCNAME}-plugin-openvswitch"
204 204
205INITSCRIPT_PACKAGES = "${SRCNAME}-server ${SRCNAME}-plugin-openvswitch ${SRCNAME}-plugin-linuxbridge" 205INITSCRIPT_PACKAGES = "${SRCNAME}-server ${SRCNAME}-plugin-openvswitch ${SRCNAME}-plugin-linuxbridge"
206INITSCRIPT_NAME_${SRCNAME}-server = "neutron-server" 206INITSCRIPT_NAME_${SRCNAME}-server = "neutron-server"
207INITSCRIPT_PARAMS_${SRCNAME}-server = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
207INITSCRIPT_NAME_${SRCNAME}-plugin-openvswitch = "neutron-openvswitch-agent" 208INITSCRIPT_NAME_${SRCNAME}-plugin-openvswitch = "neutron-openvswitch-agent"
209INITSCRIPT_PARAMS_${SRCNAME}-plugin-openvswitch = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
208INITSCRIPT_NAME_${SRCNAME}-plugin-linuxbridge = "neutron-linuxbridge-agent" 210INITSCRIPT_NAME_${SRCNAME}-plugin-linuxbridge = "neutron-linuxbridge-agent"
211INITSCRIPT_PARAMS_${SRCNAME}-plugin-linuxbridge = "${OS_DEFAULT_INITSCRIPT_PARAMS}"