summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-neutron_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:24:24 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:30:04 -0500
commit0e5297c9a87c43fe6011c240fbbe754b053da138 (patch)
treef1aa1a088ac55bee395dcfac22b701e91009e131 /meta-openstack/recipes-devtools/python/python-neutron_git.bb
parent8d106c85a99ef8450e098e627428e37386ac6b10 (diff)
downloadmeta-cloud-services-0e5297c9a87c43fe6011c240fbbe754b053da138.tar.gz
tempest: create per-component test packages and flakes8
To add more complete tempest support, we require flakes8, so it is added to the dependency list. To get the individual component test scripts onto the target, create a $PACKAGE-tests package and add the script. When the tests are required on target, these packages should be added to the install list. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-neutron_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index f33db97..18655b0 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -63,6 +63,8 @@ do_install_append() {
63 sed "s:@suffix@:$PLUGIN:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$PLUGIN.init.sh 63 sed "s:@suffix@:$PLUGIN:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$PLUGIN.init.sh
64 install -m 0755 ${WORKDIR}/neutron-$PLUGIN.init.sh ${D}${sysconfdir}/init.d/neutron-$PLUGIN-agent 64 install -m 0755 ${WORKDIR}/neutron-$PLUGIN.init.sh ${D}${sysconfdir}/init.d/neutron-$PLUGIN-agent
65 fi 65 fi
66
67 cp run_tests.sh ${NEUTRON_CONF_DIR}
66} 68}
67 69
68pkg_postinst_${SRCNAME}-setup () { 70pkg_postinst_${SRCNAME}-setup () {
@@ -93,6 +95,7 @@ ALLOW_EMPTY_${SRCNAME}-setup = "1"
93ALLOW_EMPTY_${SRCNAME}-plugin-openvswitch-setup = "1" 95ALLOW_EMPTY_${SRCNAME}-plugin-openvswitch-setup = "1"
94 96
95PACKAGES += " \ 97PACKAGES += " \
98 ${SRCNAME}-tests \
96 ${SRCNAME} \ 99 ${SRCNAME} \
97 ${SRCNAME}-doc \ 100 ${SRCNAME}-doc \
98 ${SRCNAME}-server \ 101 ${SRCNAME}-server \
@@ -108,6 +111,8 @@ PACKAGES += " \
108 111
109FILES_${PN} = "${libdir}/*" 112FILES_${PN} = "${libdir}/*"
110 113
114FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
115
111FILES_${SRCNAME} = " \ 116FILES_${SRCNAME} = " \
112 ${bindir}/neutron-db-manage \ 117 ${bindir}/neutron-db-manage \
113 ${bindir}/neutron-rootwrap \ 118 ${bindir}/neutron-rootwrap \