summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-05 12:14:54 +0900
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-05 09:56:01 -0400
commit593067153e36128a1901b53ea5d9f0ff95c29734 (patch)
tree1d1a63821b58edb3cd0cc74510c73efb26681b68 /meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb
parentaf7a6b817ea47a0b3020c1eab7bff91d1880a291 (diff)
downloadmeta-cloud-services-593067153e36128a1901b53ea5d9f0ff95c29734.tar.gz
python-mox3:upgrade 0.27.0 -> 0.28.0
Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb b/meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb
new file mode 100644
index 0000000..28ffe16
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mox3_0.28.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "mox3: mock object framework for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/mox3"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "c930d8479996541b04447a67e96e4a62"
8SRC_URI[sha256sum] = "8094868e70f814b4a526ecc592365437bc93a7dd60341321344987b3e8dba49d"
9
10inherit setuptools pypi
11
12DEPENDS += "\
13 python-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-fixtures \
24"