summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
diff options
context:
space:
mode:
authorHong Liu <hongl.fnst@cn.fujitsu.com>2018-09-11 17:29:16 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-11 16:06:28 -0400
commit01a44dabf0ee9dbe1a7f466213a23d33c397ae1d (patch)
tree377a78a93367bfb455af514231d64464321b8083 /meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
parent5b24b8d3f86bac97e5c7f70437c53eee71c5e3ae (diff)
downloadmeta-cloud-services-01a44dabf0ee9dbe1a7f466213a23d33c397ae1d.tar.gz
:python-mox3:0.25.0->0.26.0
Upgrade python-mox3 from 0.25.0 to 0.26.0. Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb b/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
new file mode 100644
index 0000000..73de2b3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "mox3: mock object framework for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/mox3/0.9.0"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "c05b14ecb25d040f00b0d5ef3b370e20"
8SRC_URI[sha256sum] = "b13c0b8459d6fb0688f9a4e70feeec43fa2cca05b727fc01156789596e083bb1"
9
10inherit setuptools pypi
11
12DEPENDS += "\
13 python-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-fixtures \
24"