summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:22:39 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:22:39 -0500
commit8d106c85a99ef8450e098e627428e37386ac6b10 (patch)
treec7db8e0c4a4236d0edcaf763e80ea69daed5e8aa /meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
parenta0c214734ab594d018354c5262b653aeb428a20b (diff)
downloadmeta-cloud-services-8d106c85a99ef8450e098e627428e37386ac6b10.tar.gz
python-flake8: introduce python-flake8 and dependencies
For full tempest test results, we require flake8 and dependencies. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb b/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
new file mode 100644
index 0000000..30c47e8
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "McCabe checker, plugin for flake8"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.rst;md5=aa0383f6aee4f5c20084a97cd13164c4"
6
7PR = "r0"
8SRCNAME = "mccabe"
9
10SRC_URI = "https://pypi.python.org/packages/source/m/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "5a3f3fa6a4bad126c88aaaa7dab682f5"
13SRC_URI[sha256sum] = "5a2a170e47de5593a6abfae1e9542bd2c3924ac62bbe4e6ed96c953c0352243a"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-prettytable \
20 python-cmd2 \
21 python-pyparsing" \ No newline at end of file