summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:24:55 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:34 -0500
commite2a6168655ac43d8fa70cfb21dc9c6713f09953c (patch)
treeb6b0757920df1f60c508c47a6ba2be1cf9d819fe /meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
parenta5a59d040b5db77a06346a516d30566a21d41586 (diff)
downloadmeta-cloud-services-e2a6168655ac43d8fa70cfb21dc9c6713f09953c.tar.gz
keystone: update to havana version
Updating the keystone OpenStack component to the havana release version. As part of this switch, we also start building out of git versus the release tarballs. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
new file mode 100644
index 0000000..827a551
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Client library for OpenStack Identity API"
2HOMEPAGE = "https://github.com/openstack/python-keystoneclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6
7PR = "r0"
8
9SRC_URI = "git://github.com/openstack/python-keystoneclient.git;branch=master"
10
11PV="git${SRCPV}"
12SRCREV="0774d5aafade9e5a5de3830de461843c4a7d59a1"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17FILES_${PN}-doc += "${datadir}/keystoneclient"
18
19RDEPENDS_${PN} += "python-iso8601 \
20 python-prettytable \
21 python-requests \
22 python-simplejson \
23 python-oslo.config \
24 "