summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
commit3b9fa62452c636c49cc1bd19436e37882c76b88c (patch)
tree3fc5e422f733d9e037f387638a459eeaeecbab61 /meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
parenta8dbfb290b485d41da1bea5dd37907db684d86fc (diff)
downloadmeta-cloud-services-3b9fa62452c636c49cc1bd19436e37882c76b88c.tar.gz
clients: add bash-completion support
Package and enable the bash completion suppor that comes with the various client packages. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index 89d8a9a..f376617 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -31,3 +31,14 @@ RDEPENDS_${PN} += "python-iso8601 \
31 python-oslo.config \ 31 python-oslo.config \
32 python-pbr \ 32 python-pbr \
33 " 33 "
34
35PACKAGECONFIG ?= "bash-completion"
36PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
37
38do_install_append() {
39 install -d ${D}/${sysconfdir}/bash_completion.d
40 install -m 664 ${S}/tools/keystone.bash_completion ${D}/${sysconfdir}/bash_completion.d
41}
42
43PACKAGES =+ "${BPN}-bash-completion"
44FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"