summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-10 16:30:58 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-13 10:29:13 -0500
commit35966f24aeb513da8693ff1c9dadaeca8cc07e71 (patch)
treeb60f9b456f4e803ebf022b0135f475dca9879e4d /meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
parentff44dffd5602f1f34873eadbb830b87b1b184063 (diff)
downloadmeta-cloud-services-35966f24aeb513da8693ff1c9dadaeca8cc07e71.tar.gz
python-keystoneclient: uprev to latest stable/pike
This package no longer contains bash-completions, so drop this part of the packaging. Remove old, no longer applicable patches. Update the list of runtime dependencies, based on required.txt. Requires the version update to python-django-openstack-auth. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb40
1 files changed, 18 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index 0b67e40..e82c5f6 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -7,16 +7,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
7SRCNAME = "keystoneclient" 7SRCNAME = "keystoneclient"
8 8
9SRC_URI = "\ 9SRC_URI = "\
10 git://github.com/openstack/python-keystoneclient.git;branch=master \ 10 git://github.com/openstack/python-keystoneclient.git;branch=stable/pike \
11 file://fix_keystoneclient_memory_leak.patch \
12 file://keystone-api-check.sh \ 11 file://keystone-api-check.sh \
13 " 12 "
14 13
15PV = "1.7.1+git${SRCPV}" 14PV = "3.13.0+git${SRCPV}"
16SRCREV = "28138b588224c6b0503620ac2e24bd37dad25370" 15SRCREV = "7ff05baa1fa56f152173651f16fc6fd181291292"
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19inherit setuptools monitor rmargparse 18inherit setuptools monitor
20 19
21FILES_${PN}-doc += "${datadir}/keystoneclient" 20FILES_${PN}-doc += "${datadir}/keystoneclient"
22 21
@@ -31,28 +30,25 @@ DEPENDS += " \
31 " 30 "
32 31
33RDEPENDS_${PN} += " \ 32RDEPENDS_${PN} += " \
34 python-iso8601 \ 33 bash \
35 python-prettytable \ 34 python-pbr \
36 python-requests \ 35 python-debtcollector \
37 python-simplejson \ 36 python-keystoneauth1 \
38 python-oslo.config \ 37 python-oslo.config \
39 python-oslo.serialization \ 38 python-oslo.i18n \
40 python-pbr \ 39 python-oslo.serialization \
41 python-argparse \ 40 python-oslo.utils \
42 " 41 python-positional \
43 42 python-requests \
44PACKAGECONFIG ?= "bash-completion" 43 python-six \
45PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion" 44 python-stevedore \
45 "
46 46
47do_install_append() { 47do_install_append() {
48 install -d ${D}/${sysconfdir}/bash_completion.d
49 install -m 664 ${S}/tools/keystone.bash_completion ${D}/${sysconfdir}/bash_completion.d
50
51 cp -r ${S}/examples ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME} 48 cp -r ${S}/examples ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}
52} 49}
53 50
54PACKAGES =+ " ${SRCNAME}-tests ${BPN}-bash-completion" 51PACKAGES =+ " ${SRCNAME}-tests"
55FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
56 52
57FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \ 53FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
58 " 54 "