summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-05-23 14:13:55 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-01 11:59:14 -0400
commita7ee783c3d047c73409c30e0248c2bdbf195ed82 (patch)
tree43415e8f1660b80771a8204ee2d09a7cef35a3eb /meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
parenta1a56e3f4d500979088a9b18a28b8cc8d42612ed (diff)
downloadmeta-cloud-services-a7ee783c3d047c73409c30e0248c2bdbf195ed82.tar.gz
python: Inherit setuptools instead of distutils for several packages
python-appdirs python-keystoneauth python-lesscpy python-os-client-config The setup scripts of these modules use setuptools instead of distutils, resulting in errors like this: | File "setup.py", line 5, in <module> | from setuptools import setup | ImportError: No module named setuptools Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb b/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
index 1fdf9e1..83582c5 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "075a9ca7a8877c5885fa2487699015e45260c4e6be119683effe0ad2ab
12 12
13S = "${WORKDIR}/${SRCNAME}-${PV}" 13S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit distutils 15inherit setuptools
16 16
17DEPENDS += " \ 17DEPENDS += " \
18 python-pbr \ 18 python-pbr \