summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:13 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:24:31 -0400
commite617d0205fc566ef70b61a75c484d78c540ef791 (patch)
treec5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff)
downloadmeta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz
Readjust the start level of openstack components
Currently all the openstack components have default start level of 20. There are other services such as glusterfs, rabbbitmq, database... are also starting at the same start level. On some platform, this can cause racing condition between services which in turn causes some of openstack components not started. By adjusting the openstack components start level to higher will ensure that system services start in the determistic way. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index bb44fe4..6966d07 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -20,7 +20,7 @@ PV="2013.2.2+git${SRCPV}"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23inherit setuptools update-rc.d identity hosts 23inherit setuptools update-rc.d identity hosts default_configs
24 24
25SERVICE_TOKEN = "password" 25SERVICE_TOKEN = "password"
26 26
@@ -143,3 +143,4 @@ RDEPENDS_${SRCNAME}-cronjobs = "cronie ${SRCNAME}"
143 143
144INITSCRIPT_PACKAGES = "${SRCNAME}" 144INITSCRIPT_PACKAGES = "${SRCNAME}"
145INITSCRIPT_NAME_${SRCNAME} = "keystone" 145INITSCRIPT_NAME_${SRCNAME} = "keystone"
146INITSCRIPT_PARAMS_${SRCNAME} = "${OS_DEFAULT_INITSCRIPT_PARAMS}"