summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-10 16:31:00 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-13 10:29:13 -0500
commitd3545ebb91d0b6546f644680763bb86d4095f251 (patch)
tree03eebe2e0bd9ebaf8c24b3ac7f8f19a1c85cf5eb /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent0c0219e96fd7d19c5175f40b419321fb5794b77d (diff)
downloadmeta-cloud-services-d3545ebb91d0b6546f644680763bb86d4095f251.tar.gz
python-keystone: uprev to latest stable/pike
Required updates to python-olso*, keystoneclient, keystonemiddleware and more. These updates have all been completed in commit prior to this uprev. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb65
1 files changed, 35 insertions, 30 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 6dfdc93..79bd0c8 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7SRCNAME = "keystone" 7SRCNAME = "keystone"
8 8
9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike \
10 file://keystone.conf \ 10 file://keystone.conf \
11 file://identity.sh \ 11 file://identity.sh \
12 file://keystone \ 12 file://keystone \
@@ -19,8 +19,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
19# file://keystone-remove-git-commands-in-tests.patch 19# file://keystone-remove-git-commands-in-tests.patch
20# file://keystone-explicitly-import-localcontext-from-oslo.me.patch 20# file://keystone-explicitly-import-localcontext-from-oslo.me.patch
21 21
22SRCREV = "8dcd82fb9c76d43f26338bee293b32f4af473ad9" 22SRCREV = "d07677aba54362a4a3aa2d165b155105ffe30d73"
23PV = "8.0.0+git${SRCPV}" 23PV = "12.0.0+git${SRCPV}"
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
@@ -75,7 +75,7 @@ do_install_append() {
75 75
76 install -d ${D}${localstatedir}/log/${SRCNAME} 76 install -d ${D}${localstatedir}/log/${SRCNAME}
77 install -m 755 -d ${KEYSTONE_CGI_DIR} 77 install -m 755 -d ${KEYSTONE_CGI_DIR}
78 install -m 755 -d ${KEYSTONE_PY_DIR} 78 #install -m 755 -d ${KEYSTONE_PY_DIR}
79 79
80 # Apache needs to read the keystone.conf 80 # Apache needs to read the keystone.conf
81 install -m 644 ${WORKDIR}/keystone.conf ${KEYSTONE_CONF_DIR}/ 81 install -m 644 ${WORKDIR}/keystone.conf ${KEYSTONE_CONF_DIR}/
@@ -87,16 +87,16 @@ do_install_append() {
87 install -m 600 ${S}${sysconfdir}/keystone.conf.sample \ 87 install -m 600 ${S}${sysconfdir}/keystone.conf.sample \
88 ${KEYSTONE_CONF_DIR}/keystone.conf.sample 88 ${KEYSTONE_CONF_DIR}/keystone.conf.sample
89 # Apache user needs to read these files. 89 # Apache user needs to read these files.
90 install -m 644 ${S}${sysconfdir}/policy.json \ 90 #install -m 644 ${S}${sysconfdir}/policy.json \
91 ${KEYSTONE_CONF_DIR}/policy.json 91 # ${KEYSTONE_CONF_DIR}/policy.json
92 install -m 644 ${S}${sysconfdir}/keystone-paste.ini \ 92 install -m 644 ${S}${sysconfdir}/keystone-paste.ini \
93 ${KEYSTONE_CONF_DIR}/keystone-paste.ini 93 ${KEYSTONE_CONF_DIR}/keystone-paste.ini
94 install -m 644 ${S}/httpd/keystone.py \ 94 #install -m 644 ${S}/httpd/keystone.py \
95 ${KEYSTONE_PY_DIR}/keystone-httpd.py 95 # ${KEYSTONE_PY_DIR}/keystone-httpd.py
96 install -m 644 ${S}/httpd/keystone.py \ 96 #install -m 644 ${S}/httpd/keystone.py \
97 ${KEYSTONE_CGI_DIR}/admin 97 # ${KEYSTONE_CGI_DIR}/admin
98 install -m 644 ${S}/httpd/keystone.py \ 98 #install -m 644 ${S}/httpd/keystone.py \
99 ${KEYSTONE_CGI_DIR}/main 99 # ${KEYSTONE_CGI_DIR}/main
100 100
101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR} 101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR}
102 102
@@ -249,37 +249,42 @@ DEPENDS += " \
249 " 249 "
250 250
251RDEPENDS_${PN} += " \ 251RDEPENDS_${PN} += " \
252 python-pycadf \ 252 python-babel \
253 python-oslo.db \ 253 python-pbr \
254 python-pam \
255 python-webob \ 254 python-webob \
256 python-eventlet \
257 python-greenlet \
258 python-pastedeploy \ 255 python-pastedeploy \
259 python-paste \ 256 python-paste \
260 python-routes \ 257 python-routes \
258 python-cryptography \
259 python-six \
261 python-sqlalchemy \ 260 python-sqlalchemy \
262 python-sqlalchemy-migrate \ 261 python-sqlalchemy-migrate \
262 python-stevedore \
263 python-passlib \ 263 python-passlib \
264 python-lxml \
265 python-iso8601 \
266 python-keystoneclient \ 264 python-keystoneclient \
267 python-openstack-nose \ 265 python-keystonemiddleware \
266 python-bcrypt \
267 python-scrypt \
268 python-oslo.cache \
269 python-oslo.concurrency \
268 python-oslo.config \ 270 python-oslo.config \
269 python-dogpile.core \ 271 python-oslo.context \
270 python-dogpile.cache \ 272 python-oslo.messaging \
271 python-pbr \ 273 python-oslo.db \
272 python-pysaml2 \ 274 python-oslo.i18n \
275 python-oslo.log \
276 python-oslo.middleware \
273 python-oslo.policy \ 277 python-oslo.policy \
278 python-oslo.serialization \
274 python-oslo.utils \ 279 python-oslo.utils \
275 python-oauthlib \ 280 python-oauthlib \
276 python-fixtures \ 281 python-pysaml2 \
277 python-oslotest \ 282 python-dogpile.cache \
278 python-functools32 \ 283 python-jsonschema \
279 python-six \
280 python-routes \
281 python-pycadf \ 284 python-pycadf \
282 python-cryptography \ 285 python-msgpack \
286 python-osprofiler \
287 python-pytz \
283 " 288 "
284 289
285RDEPENDS_${SRCNAME}-tests += " bash" 290RDEPENDS_${SRCNAME}-tests += " bash"