summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-06 12:02:20 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-07 15:13:47 -0500
commitce709c7f312f3c18e971c9338a4e82f47b596b99 (patch)
treea4afff0728695b63c0f9cbfa32b2b9e3f322b63e /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parentf01987abfa101d77a02ccaae310d040902d2966e (diff)
downloadmeta-cloud-services-ce709c7f312f3c18e971c9338a4e82f47b596b99.tar.gz
python-keystone: remove use of the 'users' group
The use of the 'users' group was associated with the addition of apache vhost support. See commit bf51fa4f053a [python-keystone: Add apache vhost server.]. The directories and files needed to be readable by the same user running apache. Since the use of RSS, definiing a common group used by multiple recipes (apache and keystone in this case) becomes more involved and we need to use FILESYSTEM_PERMS_TABLES to accomplish this. Remove the use of the 'users' group until we can evaluate if this is still required and if so we have a proper FILESYSTEM_PERMS_TABLES solution in place. This will solve build failures for 'unknown group "users"' in the interim. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 49aa530..6dfdc93 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -74,8 +74,8 @@ do_install_append() {
74 install -m 755 -d ${APACHE_CONF_DIR} 74 install -m 755 -d ${APACHE_CONF_DIR}
75 75
76 install -d ${D}${localstatedir}/log/${SRCNAME} 76 install -d ${D}${localstatedir}/log/${SRCNAME}
77 install -g users -m 755 -d ${KEYSTONE_CGI_DIR} 77 install -m 755 -d ${KEYSTONE_CGI_DIR}
78 install -g users -m 755 -d ${KEYSTONE_PY_DIR} 78 install -m 755 -d ${KEYSTONE_PY_DIR}
79 79
80 # Apache needs to read the keystone.conf 80 # Apache needs to read the keystone.conf
81 install -m 644 ${WORKDIR}/keystone.conf ${KEYSTONE_CONF_DIR}/ 81 install -m 644 ${WORKDIR}/keystone.conf ${KEYSTONE_CONF_DIR}/