summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-07-23 12:21:00 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:59 -0400
commitc9e43b535ca44d06fcd57c9c670af6da59d0edb3 (patch)
treef6ffe0812e5b4d0a45eccc22b1d87c8caf04f165 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent2075b299cfd9b8d7860eef1d4d20cc46c73d49bc (diff)
downloadmeta-cloud-services-c9e43b535ca44d06fcd57c9c670af6da59d0edb3.tar.gz
keystone: Add script to change backend to hybrid
Adding /etc/keystone/hybrid-backend-setup and convert_keystone_backend.py to set the backend for keystone to hybrid and starts openldap and restarts keystone. Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 5eef096..7ce2548 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0" 7PR = "r1"
8SRCNAME = "keystone" 8SRCNAME = "keystone"
9 9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
@@ -14,6 +14,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
14 file://openrc \ 14 file://openrc \
15 file://keystone-search-in-etc-directory-for-config-files.patch \ 15 file://keystone-search-in-etc-directory-for-config-files.patch \
16 file://keystone-remove-git-commands-in-tests.patch \ 16 file://keystone-remove-git-commands-in-tests.patch \
17 file://hybrid-backend-setup \
18 file://convert_keystone_backend.py \
17 " 19 "
18 20
19SRCREV="1070afe2cb8707ad28d43c4ea76116a941cf2131" 21SRCREV="1070afe2cb8707ad28d43c4ea76116a941cf2131"
@@ -74,14 +76,6 @@ do_install_append() {
74 sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" -i ${D}${sysconfdir}/init.d/keystone 76 sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" -i ${D}${sysconfdir}/init.d/keystone
75 77
76 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then 78 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
77 sed -i -e '/^\[identity\]/a \
78# Uncomment the following lines to enable the hybrid backend \
79# driver = keystone.identity.backends.hybrid_identity.Identity \
80#\
81# [assignment] \
82# driver = keystone.assignment.backends.hybrid_assignment.Assignment \
83' ${D}/etc/keystone/keystone.conf
84
85 sed -i -e '/^\[ldap\]/a \ 79 sed -i -e '/^\[ldap\]/a \
86url = ldap://localhost \ 80url = ldap://localhost \
87user = cn=Manager,${LDAP_DN} \ 81user = cn=Manager,${LDAP_DN} \
@@ -112,6 +106,9 @@ role_id_attribute = cn \
112role_name_attribute = ou \ 106role_name_attribute = ou \
113role_tree_dn = ou=Roles,${LDAP_DN} \ 107role_tree_dn = ou=Roles,${LDAP_DN} \
114' ${D}/etc/keystone/keystone.conf 108' ${D}/etc/keystone/keystone.conf
109
110 install -m 0755 ${WORKDIR}/hybrid-backend-setup ${D}${sysconfdir}/keystone/hybrid-backend-setup
111 install -m 0755 ${WORKDIR}/convert_keystone_backend.py ${D}${sysconfdir}/keystone/convert_keystone_backend.py
115 fi 112 fi
116} 113}
117 114