summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-03 17:06:46 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-09 09:45:08 -0400
commitc77a07631e26862073e5c1bbfece1f94da0d3208 (patch)
tree8616d61bdc74bdac139779b9704f1f95f65e3571 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parentebe7098fb5a3199f41a2fa1f36b8c594e63aba2d (diff)
downloadmeta-cloud-services-c77a07631e26862073e5c1bbfece1f94da0d3208.tar.gz
keystone: create test temporary directory
Some Keystone tests create temporary files, usually databases for testing. These files are stored in the "tmp" directory under the "tests" directory in Keystone. The fix creates this directory so these tests don't fail on failing to create temporary files because the path doesn't exist. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 4c28f78..e37e658 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -59,6 +59,8 @@ do_install_append() {
59 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 59 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
60 fi 60 fi
61 61
62 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
63
62 sed -e "s:%KEYSTONE_PACKAGE_DIR%:${PYTHON_SITEPACKAGES_DIR}/keystone:g" -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf 64 sed -e "s:%KEYSTONE_PACKAGE_DIR%:${PYTHON_SITEPACKAGES_DIR}/keystone:g" -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf
63 65
64 cp run_tests.sh ${KEYSTONE_CONF_DIR} 66 cp run_tests.sh ${KEYSTONE_CONF_DIR}