summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-03 16:31:03 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-09 09:45:08 -0400
commitc4e3732386af0df68a6d0c8ef63a0533b9847018 (patch)
treea45fda790d8322eefb78e01f4896489e37ce8678 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parenta5b0fecee722961f2853282dfd547c685cc1b697 (diff)
downloadmeta-cloud-services-c4e3732386af0df68a6d0c8ef63a0533b9847018.tar.gz
keystone: install example test certificates
Some tests provided by Keystone tests signing with an example certificate and signing key. If these certificates are not found these particular tests will hang. Thus, in order for these tests to pass we must install the example certificates to the system. This fix updates the install script for Keystone to include installing the example certificates. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index be74fd4..3f4220c 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -28,6 +28,7 @@ TOKEN_FORMAT ?= "PKI"
28do_install_append() { 28do_install_append() {
29 29
30 KEYSTONE_CONF_DIR=${D}${sysconfdir}/keystone 30 KEYSTONE_CONF_DIR=${D}${sysconfdir}/keystone
31 KEYSTONE_PACKAGE_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/keystone
31 32
32 install -m 750 -d ${KEYSTONE_CONF_DIR} 33 install -m 750 -d ${KEYSTONE_CONF_DIR}
33 34
@@ -41,6 +42,8 @@ do_install_append() {
41 install -m 600 ${S}/etc/keystone.conf.sample ${KEYSTONE_CONF_DIR}/keystone.conf.sample 42 install -m 600 ${S}/etc/keystone.conf.sample ${KEYSTONE_CONF_DIR}/keystone.conf.sample
42 install -m 600 ${S}/etc/keystone-paste.ini ${KEYSTONE_CONF_DIR}/keystone-paste.ini 43 install -m 600 ${S}/etc/keystone-paste.ini ${KEYSTONE_CONF_DIR}/keystone-paste.ini
43 44
45 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR}
46
44 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf 47 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf
45 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf 48 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf
46 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf 49 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf