summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-05-12 10:35:47 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-12 16:44:07 -0400
commit8be0a0d6836439fd326fd94bc9332b2ee424e94a (patch)
tree4ee312715183eda38555ca02fc3deac2ba9237a9 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent247b6eb6ba051c4faa1f5bed6bc507fbd9ee9547 (diff)
downloadmeta-cloud-services-8be0a0d6836439fd326fd94bc9332b2ee424e94a.tar.gz
keystone: allow ability to store tokens in UUID or PKI format
Since Grizzly release Keystone defaults to storing tokens in PKI format. Some software works better with keystone if tokens are in the older UUID format. This change allows a simple way to set the storage format within the bitbake receipes. The default is to use the newer PKI format. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index c0522f8..56a9d0a 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -23,6 +23,7 @@ S = "${WORKDIR}/git"
23inherit setuptools update-rc.d identity hosts default_configs 23inherit setuptools update-rc.d identity hosts default_configs
24 24
25SERVICE_TOKEN = "password" 25SERVICE_TOKEN = "password"
26TOKEN_FORMAT ?= "PKI"
26 27
27do_install_append() { 28do_install_append() {
28 29
@@ -46,6 +47,8 @@ do_install_append() {
46 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf 47 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf
47 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${KEYSTONE_CONF_DIR}/identity.sh 48 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${KEYSTONE_CONF_DIR}/identity.sh
48 49
50 sed -e "s:%TOKEN_FORMAT%:${TOKEN_FORMAT}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf
51
49 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 52 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
50 install -d ${D}${sysconfdir}/init.d 53 install -d ${D}${sysconfdir}/init.d
51 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 54 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone