summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 10:14:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 10:14:48 -0400
commit86b80ab2e9cbb3a7dfc1164b0205eaffcf4f2363 (patch)
tree034877b096e0940feea060aab5faef80e15aa533 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent5cd2721115351f45681aecbf2cd6798b7082c2ac (diff)
downloadmeta-cloud-services-86b80ab2e9cbb3a7dfc1164b0205eaffcf4f2363.tar.gz
keystone: update for Juno rc1
We have three changes in a single commit: - A runtime substition fix controller IP values - When the substitions were moved for chef integration, the chef disabled path wasn't tested. This meant that %CONTROLLER_IP% remained in the final config files, and broke keystone startup. - The addition of oathlib to keystone depedencies - oauthlib is a juno dependency - A temporary patch to the apache httpd front end modules - At times keystone would fail to load via apache due to the inability to load localcontext from oslo. To work around these sporadic failures, an explicit import was added to the http front end module. This will be removed in the future. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 9bdce3f..18f77ef 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r1" 7PR = "r2"
8SRCNAME = "keystone" 8SRCNAME = "keystone"
9 9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
13 file://keystone \ 13 file://keystone \
14 file://keystone-search-in-etc-directory-for-config-files.patch \ 14 file://keystone-search-in-etc-directory-for-config-files.patch \
15 file://keystone-remove-git-commands-in-tests.patch \ 15 file://keystone-remove-git-commands-in-tests.patch \
16 file://keystone-explicitly-import-localcontext-from-oslo.me.patch \
16 file://convert_keystone_backend.py \ 17 file://convert_keystone_backend.py \
17 file://wsgi-keystone.conf \ 18 file://wsgi-keystone.conf \
18 " 19 "
@@ -103,6 +104,14 @@ do_install_append() {
103 install -d ${D}${sysconfdir}/init.d 104 install -d ${D}${sysconfdir}/init.d
104 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 105 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
105 fi 106 fi
107
108 sed "/# admin_endpoint = .*/a \
109 public_endpoint = http://%CONTROLLER_IP%:8081/keystone/main/ " \
110 -i ${KEYSTONE_CONF_DIR}/keystone.conf
111
112 sed "/# admin_endpoint = .*/a \
113 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
114 -i ${KEYSTONE_CONF_DIR}/keystone.conf
106 115
107 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then 116 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then
108 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \ 117 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \
@@ -127,14 +136,6 @@ do_install_append() {
127 -i ${D}${sysconfdir}/init.d/keystone 136 -i ${D}${sysconfdir}/init.d/keystone
128 fi 137 fi
129 138
130 sed "/# admin_endpoint = .*/a \
131 public_endpoint = http://%CONTROLLER_IP%:8081/keystone/main/ " \
132 -i ${KEYSTONE_CONF_DIR}/keystone.conf
133
134 sed "/# admin_endpoint = .*/a \
135 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
136 -i ${KEYSTONE_CONF_DIR}/keystone.conf
137
138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp 139 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
139 140
140 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then 141 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then
@@ -279,6 +280,7 @@ RDEPENDS_${PN} += " \
279 python-dogpile.cache \ 280 python-dogpile.cache \
280 python-pbr \ 281 python-pbr \
281 python-oslo.utils \ 282 python-oslo.utils \
283 python-oauthlib \
282 " 284 "
283 285
284PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}" 286PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"