summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-09 10:04:10 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-09 12:23:58 -0500
commit0d6067258d09fdd47c95828e5e0e9b0f9987a529 (patch)
treedbce7395b11e577bbcd633fa0daeae24697df42e /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parent96dd0da3edc2f56de99d84ef96effdbf366a3041 (diff)
downloadmeta-cloud-services-0d6067258d09fdd47c95828e5e0e9b0f9987a529.tar.gz
chef: remove the use of chef
The use of chef was never complete, had isses with updating binary database files and had a cumbersome implementation. Since we are using Ansible in meta-overc we are dropping the use of chef here and will look to being at par with meta-overc by using Ansible if/when we get time to look at runtime configuration in meta-cloud-services. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb50
1 files changed, 21 insertions, 29 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index e79a6a4..49aa530 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -24,7 +24,7 @@ PV = "8.0.0+git${SRCPV}"
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit setuptools update-rc.d identity hosts default_configs openstackchef monitor 27inherit setuptools update-rc.d identity hosts default_configs monitor
28 28
29SERVICE_TOKEN = "password" 29SERVICE_TOKEN = "password"
30TOKEN_FORMAT ?= "PKI" 30TOKEN_FORMAT ?= "PKI"
@@ -114,28 +114,26 @@ do_install_append() {
114 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \ 114 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
115 -i ${KEYSTONE_CONF_DIR}/keystone.conf 115 -i ${KEYSTONE_CONF_DIR}/keystone.conf
116 116
117 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then 117 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \
118 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \ 118 -i ${KEYSTONE_CONF_DIR}/keystone.conf
119 -i ${KEYSTONE_CONF_DIR}/keystone.conf 119 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf
120 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${KEYSTONE_CONF_DIR}/keystone.conf 120 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" \
121 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" \ 121 -i ${KEYSTONE_CONF_DIR}/keystone.conf
122 -i ${KEYSTONE_CONF_DIR}/keystone.conf 122
123 123 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" \
124 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" \ 124 -i ${KEYSTONE_CONF_DIR}/keystone.conf
125 -i ${KEYSTONE_CONF_DIR}/keystone.conf 125 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" \
126 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" \ 126 -i ${KEYSTONE_CONF_DIR}/identity.sh
127 -i ${KEYSTONE_CONF_DIR}/identity.sh 127
128 128 sed -e "s:%TOKEN_FORMAT%:${TOKEN_FORMAT}:g" \
129 sed -e "s:%TOKEN_FORMAT%:${TOKEN_FORMAT}:g" \ 129 -i ${KEYSTONE_CONF_DIR}/keystone.conf
130 -i ${KEYSTONE_CONF_DIR}/keystone.conf 130
131 131 sed -e "s/%ADMIN_PASSWORD%/${ADMIN_PASSWORD}/g" \
132 sed -e "s/%ADMIN_PASSWORD%/${ADMIN_PASSWORD}/g" \ 132 -i ${D}${sysconfdir}/init.d/keystone
133 -i ${D}${sysconfdir}/init.d/keystone 133 sed -e "s/%SERVICE_PASSWORD%/${SERVICE_PASSWORD}/g" \
134 sed -e "s/%SERVICE_PASSWORD%/${SERVICE_PASSWORD}/g" \ 134 -i ${D}${sysconfdir}/init.d/keystone
135 -i ${D}${sysconfdir}/init.d/keystone 135 sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" \
136 sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" \ 136 -i ${D}${sysconfdir}/init.d/keystone
137 -i ${D}${sysconfdir}/init.d/keystone
138 fi
139 137
140 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp 138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
141 139
@@ -189,12 +187,6 @@ role_tree_dn = ou=Roles,${LDAP_DN} \
189 fi 187 fi
190} 188}
191 189
192CHEF_SERVICES_CONF_FILES := "\
193 ${sysconfdir}/${SRCNAME}/keystone.conf \
194 ${sysconfdir}/${SRCNAME}/identity.sh \
195 ${sysconfdir}/init.d/keystone \
196 "
197
198pkg_postinst_${SRCNAME}-setup () { 190pkg_postinst_${SRCNAME}-setup () {
199 # python-keystone postinst start 191 # python-keystone postinst start
200 if [ "x$D" != "x" ]; then 192 if [ "x$D" != "x" ]; then