summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-09-29 00:44:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-29 00:44:57 -0400
commit054a2823ebfd763c411a343ad3d5c70005abe0a5 (patch)
tree00ae0ee42e40e0985c88e4d77960167885084038 /meta-openstack/recipes-devtools/python/python-keystone_git.bb
parentd0bef02d7dfff29fc99760cb75aa7a78ae68acca (diff)
downloadmeta-cloud-services-054a2823ebfd763c411a343ad3d5c70005abe0a5.tar.gz
keystone:
keystone: move initscript install to before fixups There are sed operations being performed on the sysvinit script .. but the script wasn't being installed until after that block of code. We relocate the install of the script to above any fixups, and everything works again. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 5e7fca1..8105d6f 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -97,6 +97,12 @@ do_install_append() {
97 ${KEYSTONE_CGI_DIR}/main 97 ${KEYSTONE_CGI_DIR}/main
98 98
99 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR} 99 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR}
100
101 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
102 then
103 install -d ${D}${sysconfdir}/init.d
104 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
105 fi
100 106
101 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then 107 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then
102 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \ 108 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \
@@ -129,12 +135,6 @@ do_install_append() {
129 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \ 135 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
130 -i ${KEYSTONE_CONF_DIR}/keystone.conf 136 -i ${KEYSTONE_CONF_DIR}/keystone.conf
131 137
132 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
133 then
134 install -d ${D}${sysconfdir}/init.d
135 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
136 fi
137
138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp 138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
139 139
140 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then 140 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then