summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-04 00:27:53 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-04 13:16:33 -0400
commit608fa75973c111c61cf55e99cf3172ff3f3f00b1 (patch)
treefa3b3a3d457dc1daafdefa5c100379bcf3de1928 /meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
parent6806482a7ba6f020b0cff44b2b797eede2b702af (diff)
downloadmeta-cloud-services-608fa75973c111c61cf55e99cf3172ff3f3f00b1.tar.gz
postgresql: unify startup and initialization
Since we can't count on package postinst order, many components check for a configured postgresql daemon, and if not found, initialize it. Rather than sprinkling the knowledge of how to initialize the database through all these packages, we create a more robust, central postgresql-init script, and call it when any component needs the database configured. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
index e124583..387fa68 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
@@ -58,11 +58,9 @@ pkg_postinst_${SRCNAME} () {
58 58
59 # This is to make sure postgres is configured and running 59 # This is to make sure postgres is configured and running
60 if ! pidof postmaster > /dev/null; then 60 if ! pidof postmaster > /dev/null; then
61 sudo -u postgres initdb -D /etc/postgresql/ 61 /etc/init.d/postgresql-init
62 sleep 10
63 /etc/init.d/postgresql start 62 /etc/init.d/postgresql start
64 sleep 5 63 sleep 5
65 sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
66 fi 64 fi
67 65
68 sudo -u postgres createdb keystone 66 sudo -u postgres createdb keystone