summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-kafka_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:18 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitb53462abd2e1f2fe40fa1592431c2b11d1d81389 (patch)
tree9350c6556d6e4906eadcf711e85fa7c0e2aa4f98 /meta-openstack/recipes-devtools/python/python-kafka_git.bb
parente35b871d263edc816da0b1b0ce4beba9d4d3a664 (diff)
downloadmeta-cloud-services-b53462abd2e1f2fe40fa1592431c2b11d1d81389.tar.gz
python-kafka: initial version
This package provides a python client for Apache Kafka. This package is required by ceilometer. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-kafka_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-kafka_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-kafka_git.bb b/meta-openstack/recipes-devtools/python/python-kafka_git.bb
new file mode 100644
index 0000000..7fbb826
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-kafka_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Python client for Apache Kafka"
2HOMEPAGE = "https://github.com/mumrah/kafka-python"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5
6PV = "0.9.4+git${SRCPV}"
7SRCREV = "4955582be1443b75c23f700268b7abbef0fde0ad"
8
9SRCNAME = "kafka-python"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
12SRC_URI = "git://github.com/mumrah/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 python-six \
24 "
25