summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-07 16:29:20 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-07 16:29:20 -0400
commit4c269b936494235219916fa82c291c3bcf40b9c6 (patch)
treead4a8701c11ed292f13a19e6715e5283f39de018 /meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
parentfbbf81524bdc26eb11ff9d817ada6baa559e47cc (diff)
downloadmeta-cloud-services-4c269b936494235219916fa82c291c3bcf40b9c6.tar.gz
havana/stable:ceilometer: update and introduce package for havana/stable
The havana stable and icehouse ceilometer required two new packages and updated wsme and stevedore. So we update them here. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb b/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
new file mode 100644
index 0000000..b589053
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Google's IP address manipulation library"
2HOMEPAGE = "http://code.google.com/p/ipaddr-py/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d8b8c1199001505d7b77da5db34ba441"
6
7PR = "r0"
8
9SRCNAME = "ipaddr"
10SRC_URI = "http://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "f2c7852f95862715f92e7d089dc3f2cf"
13SRC_URI[sha256sum] = "1b555b8a8800134fdafe32b7d0cb52f5bdbfdd093707c3dd484c5ea59f1d98b7"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += " \
25 python-pbr \
26 "