summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 16:48:05 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:40:01 -0500
commit3d512115129e2cea97067d23cb72fea62b70dd39 (patch)
treed891dce76b3cfa2bcb2b4afaf04704fa862da1f6 /meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
parentb63d5e8f9d1a6ce468d8c327fbdc6bdcff357ee2 (diff)
downloadmeta-cloud-services-3d512115129e2cea97067d23cb72fea62b70dd39.tar.gz
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes using archived versions of packages we must set PYPI_SRC_URI to overwrite what the pypi class would derive. For example when the archive is a zip and not a tar.gz. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb b/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
index d0d39f6..501e895 100644
--- a/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
+++ b/meta-openstack/recipes-devtools/python/python-ipaddr_2.1.11.bb
@@ -4,17 +4,10 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d8b8c1199001505d7b77da5db34ba441" 5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d8b8c1199001505d7b77da5db34ba441"
6 6
7PR = "r0"
8
9SRCNAME = "ipaddr"
10SRC_URI = "http://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "f2c7852f95862715f92e7d089dc3f2cf" 7SRC_URI[md5sum] = "f2c7852f95862715f92e7d089dc3f2cf"
13SRC_URI[sha256sum] = "1b555b8a8800134fdafe32b7d0cb52f5bdbfdd093707c3dd484c5ea59f1d98b7" 8SRC_URI[sha256sum] = "1b555b8a8800134fdafe32b7d0cb52f5bdbfdd093707c3dd484c5ea59f1d98b7"
14 9
15S = "${WORKDIR}/${SRCNAME}-${PV}" 10inherit distutils pypi
16
17inherit distutils
18 11
19DEPENDS += " \ 12DEPENDS += " \
20 python-pip \ 13 python-pip \