summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-horizon_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-05-30 12:55:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 10:17:07 -0400
commitb06874fd38f3c2e77fb6f1950f4f70a3dbeca418 (patch)
treed18f670afff95fea393a35f6c35be5a2f31482b9 /meta-openstack/recipes-devtools/python/python-horizon_git.bb
parent74d156db9f696cf9b3a4fbe9c006605198e261da (diff)
downloadmeta-cloud-services-b06874fd38f3c2e77fb6f1950f4f70a3dbeca418.tar.gz
horizon: add full path to test directories
The tests included Horizon expect all files to be in a single location in order to be run directly from the source tree. The recipe for installing Horizon on the system installs Horizon as a python site-package and puts files in different locations depending on the file type. In order to have the tests support this type of install we need to explicitly indicate the full path of the test files to exclude in order to have the tests run successfully. This fix adds the absolute path to the test locations allows the Horizon tests to pass as expected. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-horizon_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 3924fc8..3f9e5e6 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -38,7 +38,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \
38 file://fix_bindir_path.patch \ 38 file://fix_bindir_path.patch \
39 file://openstack-dashboard-apache.conf \ 39 file://openstack-dashboard-apache.conf \
40 file://local_settings.py \ 40 file://local_settings.py \
41 file://horizon-fix-test-script-to-not-require-coverage-tool.patch \ 41 file://horizon-use-full-package-path-to-test-directories.patch \
42 " 42 "
43 43
44SRCREV="0c3b71055c0d169b8245aee773438dbcb46c2bcf" 44SRCREV="0c3b71055c0d169b8245aee773438dbcb46c2bcf"
@@ -69,6 +69,7 @@ do_install_append() {
69 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' ${WORKDIR}/horizon.init >${WORKDIR}/horizon 69 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' ${WORKDIR}/horizon.init >${WORKDIR}/horizon
70 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon 70 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon
71 fi 71 fi
72 sed -i -e 's#%PYTHON_SITEPACKAGES%#${PYTHON_SITEPACKAGES_DIR}#g' ${D}${PYTHON_SITEPACKAGES_DIR}/horizon/test/settings.py
72 73
73 # no longer required. kept as reference. 74 # no longer required. kept as reference.
74 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin 75 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin