summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-horizon_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:24:24 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:30:04 -0500
commit0e5297c9a87c43fe6011c240fbbe754b053da138 (patch)
treef1aa1a088ac55bee395dcfac22b701e91009e131 /meta-openstack/recipes-devtools/python/python-horizon_git.bb
parent8d106c85a99ef8450e098e627428e37386ac6b10 (diff)
downloadmeta-cloud-services-0e5297c9a87c43fe6011c240fbbe754b053da138.tar.gz
tempest: create per-component test packages and flakes8
To add more complete tempest support, we require flakes8, so it is added to the dependency list. To get the individual component test scripts onto the target, create a $PACKAGE-tests package and add the script. When the tests are required on target, these packages should be added to the install list. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-horizon_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 789192c..281264c 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -39,6 +39,10 @@ inherit setuptools update-rc.d python-dir
39# do_install[dirs] += "${D}/usr/share/bin" 39# do_install[dirs] += "${D}/usr/share/bin"
40 40
41do_install_append() { 41do_install_append() {
42 HORIZON_CONF_DIR=${D}${sysconfdir}/horizon
43
44 install -d ${HORIZON_CONF_DIR}
45
42 DASHBOARD_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/openstack_dashboard 46 DASHBOARD_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/openstack_dashboard
43 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \ 47 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \
44 -i ${DASHBOARD_DIR}/settings.py 48 -i ${DASHBOARD_DIR}/settings.py
@@ -56,12 +60,16 @@ do_install_append() {
56 60
57 # no longer required. kept as reference. 61 # no longer required. kept as reference.
58 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin 62 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin
63
64 cp run_tests.sh ${HORIZON_CONF_DIR}
59} 65}
60 66
61PACKAGES += "${SRCNAME}" 67PACKAGES += "${SRCNAME}-tests ${SRCNAME}"
62 68
63FILES_${PN} = "${libdir}/*" 69FILES_${PN} = "${libdir}/*"
64 70
71FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
72
65FILES_${SRCNAME} = "${bindir}/* \ 73FILES_${SRCNAME} = "${bindir}/* \
66 ${sysconfdir}/init.d/* \ 74 ${sysconfdir}/init.d/* \
67 ${datadir}/* \ 75 ${datadir}/* \