summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:54:13 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:35 -0500
commitb5340184a98413b1f923be8712723ff928e2b7ca (patch)
tree2eadba5503c8796cbd9f828bac3a091533d1fcdf /meta-openstack/recipes-devtools/python/python-heatclient_git.bb
parent3b81f3d5bb38fc67bb9ffb06b75385aebd60ae3b (diff)
downloadmeta-cloud-services-b5340184a98413b1f923be8712723ff928e2b7ca.tar.gz
python-heatclient: introduce heat client and API
To support the havana horizon dashboard we need at least the heat client APIs available on the controller. We introduce this package first, and the full heat implementation later. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heatclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
new file mode 100644
index 0000000..435ab1f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "CLI and python client library for OpenStack Heat"
2HOMEPAGE = "https://launchpad.net/heat"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \
9 python-iso8601 \
10 python-prettytable \
11 python-pyparsing \
12 python-simplejson \
13 "
14
15PR = "r0"
16
17SRC_URI = "git://github.com/openstack/python-heatclient.git;branch=master"
18
19PV="git${SRCPV}"
20SRCREV="30032302f359985335d50e80abb03ba901143168"
21S = "${WORKDIR}/git"
22
23inherit setuptools