summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
commit3b9fa62452c636c49cc1bd19436e37882c76b88c (patch)
tree3fc5e422f733d9e037f387638a459eeaeecbab61 /meta-openstack/recipes-devtools/python/python-heatclient_git.bb
parenta8dbfb290b485d41da1bea5dd37907db684d86fc (diff)
downloadmeta-cloud-services-3b9fa62452c636c49cc1bd19436e37882c76b88c.tar.gz
clients: add bash-completion support
Package and enable the bash completion suppor that comes with the various client packages. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heatclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
index fc9f020..9902de1 100644
--- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -27,3 +27,15 @@ SRCREV="55e794f922dd2005a62bb33fd129996b6c476b66"
27S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
28 28
29inherit setuptools 29inherit setuptools
30
31
32PACKAGECONFIG ?= "bash-completion"
33PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
34
35do_install_append() {
36 install -d ${D}/${sysconfdir}/bash_completion.d
37 install -m 664 ${S}/tools/heat.bash_completion ${D}/${sysconfdir}/bash_completion.d
38}
39
40PACKAGES =+ "${BPN}-bash-completion"
41FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"