summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heat_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-10 13:57:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-10 14:01:05 -0400
commit825048fe5ef82644ae5bb2833e71b295e759d7e1 (patch)
tree6e625274dbfac874ebe477d31db9cddc4f65534a /meta-openstack/recipes-devtools/python/python-heat_git.bb
parentb1a41b17310a3081aeead1b7b9c2056e8f04ab14 (diff)
downloadmeta-cloud-services-825048fe5ef82644ae5bb2833e71b295e759d7e1.tar.gz
core: BROKEN: Initial update to kilo branches and REVs
This is the initial update to the kilo branches and SRCREVs for some of the core projects. These are known to NOT work, due to SSLv3 issues with oe-core, and missing config/dependencies. Incremental updates will fix issues with the components, but they are best done in-tree, rather than sitting on a huge pile of changes. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heat_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 8718147..87e93c7 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7PR = "r0" 7PR = "r0"
8SRCNAME = "heat" 8SRCNAME = "heat"
9 9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/juno \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://heat.conf \ 11 file://heat.conf \
12 file://heat.init \ 12 file://heat.init \
13 file://autoscaling_example.template \ 13 file://autoscaling_example.template \
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/juno \
16 file://heat-tests-change-project_dir-path.patch \ 16 file://heat-tests-change-project_dir-path.patch \
17" 17"
18 18
19SRCREV="5664854f372b9810d040c615d8a678dbfdfb880e" 19SRCREV="6d106dee26649202791596062b5a29049e962d80"
20PV="2014.2+git${SRCPV}" 20PV="2015.1.0b2+git${SRCPV}"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn" 23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn"
@@ -103,7 +103,9 @@ do_install_append() {
103 install -m 0755 ${WORKDIR}/heat-engine.init.sh ${D}${sysconfdir}/init.d/heat-engine 103 install -m 0755 ${WORKDIR}/heat-engine.init.sh ${D}${sysconfdir}/init.d/heat-engine
104 fi 104 fi
105 105
106 cp run_tests.sh ${HEAT_CONF_DIR} 106 if [ -e "run_tests.sh" ]; then
107 cp run_tests.sh ${HEAT_CONF_DIR}
108 fi
107} 109}
108 110
109CHEF_SERVICES_CONF_FILES :="\ 111CHEF_SERVICES_CONF_FILES :="\
@@ -135,7 +137,7 @@ PACKAGES += "${SRCNAME}-cfn"
135 137
136RDEPENDS_${SRCNAME}-tests += " bash" 138RDEPENDS_${SRCNAME}-tests += " bash"
137 139
138 140ALLOW_EMPTY_${SRCNAME}-tests = "1"
139ALLOW_EMPTY_${SRCNAME}-setup = "1" 141ALLOW_EMPTY_${SRCNAME}-setup = "1"
140ALLOW_EMPTY_${SRCNAME}-templates = "1" 142ALLOW_EMPTY_${SRCNAME}-templates = "1"
141ALLOW_EMPTY_${SRCNAME}-cfn = "1" 143ALLOW_EMPTY_${SRCNAME}-cfn = "1"
@@ -210,6 +212,7 @@ RDEPENDS_${PN} += " \
210 python-pip \ 212 python-pip \
211 python-pytz \ 213 python-pytz \
212 python-pbr \ 214 python-pbr \
215 python-oslo.log \
213 " 216 "
214 217
215RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-templates ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt ${SRCNAME}-cfn" 218RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-templates ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt ${SRCNAME}-cfn"