summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heat_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-15 12:59:53 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-15 15:53:38 -0500
commit3051160f23fe8e06e545859538c86ef3a3c39d7a (patch)
tree97f922e30173df31dda04f10cca3beea27652eb8 /meta-openstack/recipes-devtools/python/python-heat_git.bb
parent3d512115129e2cea97067d23cb72fea62b70dd39 (diff)
downloadmeta-cloud-services-3051160f23fe8e06e545859538c86ef3a3c39d7a.tar.gz
python-*: fixup postinst scripts
Checking for "$D" and doing an "exit 1" now results in errors such as: [log_check] warning: %post(keystone-cronjobs-...) scriptlet failed, exit status 2 during image creation. Instead of escaping the script for "level-1" (image creation postinst) we wrap the "level-2" (first boot) postinst in an if statement. This also ensure the scriptlet in indentity.bbclass is less prone to behaving differently based on the postinsts defined in the classes which inherit 'identity'. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heat_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb24
1 files changed, 11 insertions, 13 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index cccaf0a..2cf7ce4 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -107,20 +107,18 @@ do_install_append() {
107} 107}
108 108
109pkg_postinst_${SRCNAME}-setup () { 109pkg_postinst_${SRCNAME}-setup () {
110 if [ "x$D" != "x" ]; then 110 if [ -z "$D" ]; then
111 exit 1 111 # This is to make sure postgres is configured and running
112 if ! pidof postmaster > /dev/null; then
113 /etc/init.d/postgresql-init
114 /etc/init.d/postgresql start
115 sleep 2
116 fi
117
118 mkdir /var/log/heat
119 sudo -u postgres createdb heat
120 heat-manage db_sync
112 fi 121 fi
113
114 # This is to make sure postgres is configured and running
115 if ! pidof postmaster > /dev/null; then
116 /etc/init.d/postgresql-init
117 /etc/init.d/postgresql start
118 sleep 2
119 fi
120
121 mkdir /var/log/heat
122 sudo -u postgres createdb heat
123 heat-manage db_sync
124} 122}
125 123
126inherit setuptools identity hosts update-rc.d default_configs monitor 124inherit setuptools identity hosts update-rc.d default_configs monitor