summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heat_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-05-14 16:11:41 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-21 14:35:25 -0400
commit18e871ba58697e651f8036cae4d41f631cf218d8 (patch)
treef172736da7991c7186bc2067a7740a956d02f182 /meta-openstack/recipes-devtools/python/python-heat_git.bb
parent385c8fa44a1f46ad785531eee1227382e5beb8e4 (diff)
downloadmeta-cloud-services-18e871ba58697e651f8036cae4d41f631cf218d8.tar.gz
heat: add example hot templates
Add 2 hot templates which can be used to create heat stack for demonstrating heat stack lifecycle management and autoscaling Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heat_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 6f785df..4d8b832 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -10,6 +10,9 @@ SRCNAME = "heat"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \
11 file://heat.conf \ 11 file://heat.conf \
12 file://heat.init \ 12 file://heat.init \
13 file://autoscaling_example.template \
14 file://one_vm_example.template \
15 file://two_vms_example.template \
13" 16"
14 17
15SRCREV="69145518cb9a20d401c4213a030c39caaad1c326" 18SRCREV="69145518cb9a20d401c4213a030c39caaad1c326"
@@ -25,6 +28,7 @@ do_install_append() {
25 install -m 600 ${TEMPLATE_CONF_DIR}/*.json ${HEAT_CONF_DIR} 28 install -m 600 ${TEMPLATE_CONF_DIR}/*.json ${HEAT_CONF_DIR}
26 install -d ${HEAT_CONF_DIR}/templates 29 install -d ${HEAT_CONF_DIR}/templates
27 install -m 600 ${TEMPLATE_CONF_DIR}/templates/* ${HEAT_CONF_DIR}/templates 30 install -m 600 ${TEMPLATE_CONF_DIR}/templates/* ${HEAT_CONF_DIR}/templates
31 install -m 600 ${WORKDIR}/*.template ${HEAT_CONF_DIR}/templates
28 install -d ${HEAT_CONF_DIR}/environment.d 32 install -d ${HEAT_CONF_DIR}/environment.d
29 install -m 600 ${TEMPLATE_CONF_DIR}/environment.d/* ${HEAT_CONF_DIR}/environment.d 33 install -m 600 ${TEMPLATE_CONF_DIR}/environment.d/* ${HEAT_CONF_DIR}/environment.d
30 install -m 664 ${TEMPLATE_CONF_DIR}/api-paste.ini ${HEAT_CONF_DIR} 34 install -m 664 ${TEMPLATE_CONF_DIR}/api-paste.ini ${HEAT_CONF_DIR}
@@ -82,7 +86,7 @@ pkg_postinst_${SRCNAME}-setup () {
82 86
83inherit setuptools identity hosts update-rc.d default_configs 87inherit setuptools identity hosts update-rc.d default_configs
84 88
85PACKAGES += "${SRCNAME}-tests ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine" 89PACKAGES += "${SRCNAME}-tests ${SRCNAME}-templates ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine"
86PACKAGES += "${SRCNAME}-setup" 90PACKAGES += "${SRCNAME}-setup"
87 91
88ALLOW_EMPTY_${SRCNAME}-setup = "1" 92ALLOW_EMPTY_${SRCNAME}-setup = "1"
@@ -91,6 +95,8 @@ FILES_${PN} = "${libdir}/*"
91 95
92FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 96FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
93 97
98FILES_${SRCNAME}-templates = "${sysconfdir}/${SRCNAME}/templates/*"
99
94FILES_${SRCNAME}-common = "${sysconfdir}/${SRCNAME}/* \ 100FILES_${SRCNAME}-common = "${sysconfdir}/${SRCNAME}/* \
95" 101"
96 102
@@ -157,7 +163,7 @@ RDEPENDS_${PN} += " \
157 python-pbr \ 163 python-pbr \
158 " 164 "
159 165
160RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt" 166RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-templates ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt"
161RDEPENDS_${SRCNAME}-api = "${SRCNAME}-engine" 167RDEPENDS_${SRCNAME}-api = "${SRCNAME}-engine"
162RDEPENDS_${SRCNAME}-api-cfn = "${SRCNAME}-engine" 168RDEPENDS_${SRCNAME}-api-cfn = "${SRCNAME}-engine"
163RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-engine" 169RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-engine"