summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-08-30 13:46:27 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-03 15:51:20 -0400
commit97fb59d6183ddbc78f5cb7f95cb9ba88c470fd8e (patch)
treefff4653ed737e1589a509227894b2d5d955f7de9 /meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
parent76779b613ed16667d1c39dfad4b91620e9549f89 (diff)
downloadmeta-cloud-services-97fb59d6183ddbc78f5cb7f95cb9ba88c470fd8e.tar.gz
python-happybase: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb20
1 files changed, 2 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb b/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
index a8066b6..26e39a8 100644
--- a/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-happybase_1.2.0.bb
@@ -1,18 +1,2 @@
1DESCRIPTION = "Python library to interact with Apache HBase" 1inherit setuptools
2HOMEPAGE = "https://pypi.python.org/pypi/happybase/" 2require python-happybase.inc
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
6
7SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
8SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
9
10inherit setuptools pypi
11
12do_install_append() {
13 perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
14 perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
15 for f in $perm_files; do
16 chmod 644 "${f}"
17 done
18}