summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-happybase_0.9.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-03 14:41:30 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-03 14:42:30 -0500
commit1bd3d61e2c24a8f404ee41fb291c401a9fc9c937 (patch)
tree7fd3f52c7cccf6c49489670f55ecd04c3b218cfc /meta-openstack/recipes-devtools/python/python-happybase_0.9.bb
parent560820a900f04b45f44a0335c88e1a3596cf509f (diff)
downloadmeta-cloud-services-1bd3d61e2c24a8f404ee41fb291c401a9fc9c937.tar.gz
support-libs: refresh round1
Refreshing the support libraries to prepare for kilo uprevs of the core components. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-happybase_0.9.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-happybase_0.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-happybase_0.9.bb b/meta-openstack/recipes-devtools/python/python-happybase_0.9.bb
new file mode 100644
index 0000000..b37907c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-happybase_0.9.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Python library to interact with Apache HBase"
2HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
6
7PR = "r0"
8SRCNAME = "happybase"
9
10SRC_URI = "https://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "0d9ca6e22a7edb03ccd75e99d0acf1ea"
13SRC_URI[sha256sum] = "744e342936f6c9e384b203435c38ff21a339626a0d7c11aa177988b5e164ef2a"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19do_install_append() {
20 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
21 for f in $perm_files; do
22 chmod 644 "${f}"
23 done
24}