summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-09-16 15:23:36 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-16 15:24:51 -0400
commitde5ae282c8a20ea90ac95898e7cf20912356eef7 (patch)
tree64c684226c491a2dc214ebfe6409b16d687e3abe /meta-openstack/recipes-devtools/python/python-glancestore_git.bb
parent83fee5b3333cce58ad5fa20e02ce43e5939c2b0e (diff)
downloadmeta-cloud-services-de5ae282c8a20ea90ac95898e7cf20912356eef7.tar.gz
glancestore: introduce glancestore project
The storage backends have been factored out of the core glance repository. So we introduce glancestore to meet the backend requirements of glance. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glancestore_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glancestore_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
new file mode 100644
index 0000000..33feae3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Glance's stores library"
2HOMEPAGE = "https://github.com/openstack/glance_store"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCREV = "32d5baa37d1efe1f5372d0171c7edcd719885db6"
8PV = "0.1.7+git${SRCPV}"
9
10SRC_URI = "\
11 git://github.com/openstack/glance_store.git \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18DEPENDS += " \
19 gmp \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} = " \
25 python-eventlet \
26 python-iso8601 \
27 python-six \
28 python-cinderclient \
29 python-oslo.config \
30 python-oslo.i18n \
31 "
32