summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:13 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:24:31 -0400
commite617d0205fc566ef70b61a75c484d78c540ef791 (patch)
treec5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-glance_git.bb
parent2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff)
downloadmeta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz
Readjust the start level of openstack components
Currently all the openstack components have default start level of 20. There are other services such as glusterfs, rabbbitmq, database... are also starting at the same start level. On some platform, this can cause racing condition between services which in turn causes some of openstack components not started. By adjusting the openstack components start level to higher will ensure that system services start in the determistic way. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 1bd24d0..3ccb860 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -16,7 +16,7 @@ PV="2013.2.2+git${SRCPV}"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit setuptools update-rc.d identity 19inherit setuptools update-rc.d identity default_configs
20 20
21do_install_append() { 21do_install_append() {
22 TEMPLATE_CONF_DIR=${S}${sysconfdir} 22 TEMPLATE_CONF_DIR=${S}${sysconfdir}
@@ -137,4 +137,6 @@ RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}"
137 137
138INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-registry" 138INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-registry"
139INITSCRIPT_NAME_${SRCNAME}-api = "glance-api" 139INITSCRIPT_NAME_${SRCNAME}-api = "glance-api"
140INITSCRIPT_PARAMS_${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
140INITSCRIPT_NAME_${SRCNAME}-registry = "glance-registry" 141INITSCRIPT_NAME_${SRCNAME}-registry = "glance-registry"
142INITSCRIPT_PARAMS_${SRCNAME}-registry = "${OS_DEFAULT_INITSCRIPT_PARAMS}"