summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-08-12 12:23:25 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-27 10:39:46 -0400
commit89eed297ec82f9e3ec4befc182cd29b772257e79 (patch)
tree4dd462efa781aa4a38db3e49c0a6b7c3fc8db603 /meta-openstack/recipes-devtools/python/python-glance_git.bb
parent6401ae209fb075981ace2c746f68794a59853cb1 (diff)
downloadmeta-cloud-services-89eed297ec82f9e3ec4befc182cd29b772257e79.tar.gz
Keystone: package service/user addition sstate vardeps
Several packages utilize the keystone package service/user addition services recently added. The data passed to this service depends on the value assigned to CONTROLLER_IP (used as KEYSTONE_HOST), however, bitbake is not able to automatically determine this dependency so several tasks which should be rerun to create updated package postinst scripts are not run when CONTROLLER_IP is modified. Adding the necessary vardeps ensure these tasks are rerun and now adjustments made to CONTROLLER_IP are reflected in the generated packages. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 0083925..b3d3ee1 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -46,6 +46,7 @@ python () {
46 46
47 d.setVarFlags("SERVICECREATE_PARAM_%s-setup" % d.getVar('SRCNAME',True), flags) 47 d.setVarFlags("SERVICECREATE_PARAM_%s-setup" % d.getVar('SRCNAME',True), flags)
48} 48}
49SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST"
49 50
50do_install_prepend() { 51do_install_prepend() {
51 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/functional/__init__.py 52 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/functional/__init__.py