summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:34 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit6dc7b04104dc4fc8240621b4b98cce9c5799eff9 (patch)
tree020816f2844fc72105797e26fb5ee4fb5fba99d5 /meta-openstack/recipes-devtools/python/python-glance_git.bb
parent0b712214df95d079962cb5682ca75924c9c86ffc (diff)
downloadmeta-cloud-services-6dc7b04104dc4fc8240621b4b98cce9c5799eff9.tar.gz
glance: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb31
1 files changed, 26 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 79235af..e6f5f5f 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -4,18 +4,17 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "glance" 7SRCNAME = "glance"
9 8
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://glance.init \ 10 file://glance.init \
12 " 11 "
13 12
14# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch 13# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch
15# file://glance-change-builtin-tests-config-location.patch 14# file://glance-change-builtin-tests-config-location.patch
16 15
17SRCREV = "93b0d5fce3a41e4a3a549f98f78b6681cbc3ea95" 16SRCREV = "69516fad5f651a085a047a337a05c58b39023c1b"
18PV = "2015.1.0+git${SRCPV}" 17PV = "11.0.0+git${SRCPV}"
19 18
20S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
21 20
@@ -150,7 +149,10 @@ pkg_postinst_${SRCNAME}-setup () {
150PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry" 149PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry"
151ALLOW_EMPTY_${SRCNAME}-setup = "1" 150ALLOW_EMPTY_${SRCNAME}-setup = "1"
152 151
153FILES_${PN} = "${libdir}/*" 152FILES_${PN} = " \
153 ${libdir}/* \
154 ${datadir}/etc/${SRCNAME}* \
155 "
154 156
155FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 157FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
156 158
@@ -201,6 +203,25 @@ RDEPENDS_${PN} += "python-greenlet \
201 python-enum34 \ 203 python-enum34 \
202 python-semantic-version \ 204 python-semantic-version \
203 python-oslo.vmware \ 205 python-oslo.vmware \
206 python-oslo.concurrency \
207 python-oslo.context \
208 python-oslo.service \
209 python-oslo.utils \
210 python-stevedore \
211 python-futurist \
212 python-taskflow \
213 python-keystonemiddleware \
214 python-wsme \
215 python-pyopenssl \
216 python-six \
217 python-oslo.db \
218 python-oslo.log \
219 python-oslo.messaging \
220 python-oslo.middleware \
221 python-oslo.policy \
222 python-oslo.serialization \
223 python-castellan \
224 python-cryptography \
204 " 225 "
205 226
206RDEPENDS_${SRCNAME} = "${PN} \ 227RDEPENDS_${SRCNAME} = "${PN} \