summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-04-09 19:59:24 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-11 14:15:28 -0400
commit49f5cf2454fdd702edbc0cb1f7c767f273d3de31 (patch)
tree770684f792fd0d44064ce2bd0125496c308a241a /meta-openstack/recipes-devtools/python/python-glance_git.bb
parent998b51ee74330db79c27e437b224b0485c64c566 (diff)
downloadmeta-cloud-services-49f5cf2454fdd702edbc0cb1f7c767f273d3de31.tar.gz
glance: enable swift backend
Modify glance config file to allow it to be able to use Swift as backend driver. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 5bc3c68..d2f5f21 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -41,6 +41,12 @@ do_install_append() {
41 sed -e "s:^notifier_strategy = noop:notifier_strategy = rabbit:g" \ 41 sed -e "s:^notifier_strategy = noop:notifier_strategy = rabbit:g" \
42 -i ${WORKDIR}/glance-api.conf 42 -i ${WORKDIR}/glance-api.conf
43 43
44 sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf
45 sed 's:^swift_store_auth_address =.*:swift_store_auth_address = http\://127.0.0.1\:5000/v2.0/:g' -i ${WORKDIR}/glance-api.conf
46 sed 's:^swift_store_user =.*:swift_store_user = ${SERVICE_TENANT_NAME}\:${SRCNAME}:g' -i ${WORKDIR}/glance-api.conf
47 sed 's:^swift_store_key =.*:swift_store_key = ${SERVICE_PASSWORD}:g' -i ${WORKDIR}/glance-api.conf
48 sed 's:^swift_store_create_container_on_put =.*:swift_store_create_container_on_put = True:g' -i ${WORKDIR}/glance-api.conf
49
44 install -d ${GLANCE_CONF_DIR} 50 install -d ${GLANCE_CONF_DIR}
45 install -m 600 ${WORKDIR}/glance-registry.conf ${GLANCE_CONF_DIR}/ 51 install -m 600 ${WORKDIR}/glance-registry.conf ${GLANCE_CONF_DIR}/
46 install -m 600 ${WORKDIR}/glance-api.conf ${GLANCE_CONF_DIR}/ 52 install -m 600 ${WORKDIR}/glance-api.conf ${GLANCE_CONF_DIR}/
@@ -63,8 +69,6 @@ do_install_append() {
63 install -m 0755 ${WORKDIR}/glance-registry.init.sh ${D}${sysconfdir}/init.d/glance-registry 69 install -m 0755 ${WORKDIR}/glance-registry.init.sh ${D}${sysconfdir}/init.d/glance-registry
64 fi 70 fi
65 71
66 sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf
67
68 cp run_tests.sh ${GLANCE_CONF_DIR} 72 cp run_tests.sh ${GLANCE_CONF_DIR}
69} 73}
70 74