summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-03-18 21:01:03 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-24 16:41:59 -0400
commit37cc0a34722fe53b8b532694ac686bbb995fe665 (patch)
tree21126e01f5892efc67254b518a0a5a5512f62023 /meta-openstack/recipes-devtools/python/python-glance_git.bb
parent9d2da32a9c7a3630c01c0e2360ee452860a5bdb7 (diff)
downloadmeta-cloud-services-37cc0a34722fe53b8b532694ac686bbb995fe665.tar.gz
glance: make default_store configurable
The "default_store" option in /etc/glance/glance-api.conf controls how glance store images. Make this option configurable through variable GLANCE_DEFAULT_STORE. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 3ccb860..41d6046 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
18 18
19inherit setuptools update-rc.d identity default_configs 19inherit setuptools update-rc.d identity default_configs
20 20
21GLANCE_DEFAULT_STORE ?= "file"
22
21do_install_append() { 23do_install_append() {
22 TEMPLATE_CONF_DIR=${S}${sysconfdir} 24 TEMPLATE_CONF_DIR=${S}${sysconfdir}
23 GLANCE_CONF_DIR=${D}${sysconfdir}/glance 25 GLANCE_CONF_DIR=${D}${sysconfdir}/glance
@@ -61,6 +63,8 @@ do_install_append() {
61 install -m 0755 ${WORKDIR}/glance-registry.init.sh ${D}${sysconfdir}/init.d/glance-registry 63 install -m 0755 ${WORKDIR}/glance-registry.init.sh ${D}${sysconfdir}/init.d/glance-registry
62 fi 64 fi
63 65
66 sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf
67
64 cp run_tests.sh ${GLANCE_CONF_DIR} 68 cp run_tests.sh ${GLANCE_CONF_DIR}
65} 69}
66 70