summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorLiam R. Howlett <Liam.Howlett@WindRiver.com>2014-09-19 15:52:17 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-22 11:46:43 -0400
commit1c34736247f8ae18d054cfecfec54152bf27f1d9 (patch)
treef5c2a952d804fc43c00e1be89751551b579aa6c0 /meta-openstack/recipes-devtools/python/python-glance_git.bb
parentbf51fa4f053a6aecb816ed7b4dcca64e9bd5b9b3 (diff)
downloadmeta-cloud-services-1c34736247f8ae18d054cfecfec54152bf27f1d9.tar.gz
keystone: Change packages configuration to use apache keystone.
This commit changes all required configurations to use keystone running on apache. The following packages configurations were modified for keystone running on apache: python-neutron, python-nova, tempest, python-swift, python-rally, python-heat, python-glance, python-cinder, python-ceilmoeter, python-horizon. Signed-off-by: Liam R. Howlett <Liam.Howlett@WindRiver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 52c0ebf..7775956 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -68,6 +68,7 @@ do_install_append() {
68 -i ${WORKDIR}/glance-$file.conf 68 -i ${WORKDIR}/glance-$file.conf
69 sed -e "s!^#connection =.*!connection = postgresql://${DB_USER}:${DB_PASSWORD}@localhost/glance!g" \ 69 sed -e "s!^#connection =.*!connection = postgresql://${DB_USER}:${DB_PASSWORD}@localhost/glance!g" \
70 -i ${WORKDIR}/glance-$file.conf 70 -i ${WORKDIR}/glance-$file.conf
71 sed -i '/\[keystone_authtoken\]/aidentity_uri=http://127.0.0.1:8081/keystone/admin' ${WORKDIR}/glance-$file.conf
71 done 72 done
72 sed -e "s:^filesystem_store_datadir =.*:filesystem_store_datadir = ${sysconfdir}/${SRCNAME}/images/:g" \ 73 sed -e "s:^filesystem_store_datadir =.*:filesystem_store_datadir = ${sysconfdir}/${SRCNAME}/images/:g" \
73 -i ${WORKDIR}/glance-api.conf 74 -i ${WORKDIR}/glance-api.conf
@@ -77,7 +78,7 @@ do_install_append() {
77 -i ${WORKDIR}/glance-api.conf 78 -i ${WORKDIR}/glance-api.conf
78 79
79 sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf 80 sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf
80 sed 's:^swift_store_auth_address =.*:swift_store_auth_address = http\://127.0.0.1\:5000/v2.0/:g' -i ${WORKDIR}/glance-api.conf 81 sed 's:^swift_store_auth_address =.*:swift_store_auth_address = http\://127.0.0.1\:8081/keystone/main/:g' -i ${WORKDIR}/glance-api.conf
81 sed 's:^swift_store_user =.*:swift_store_user = ${SERVICE_TENANT_NAME}\:${SRCNAME}:g' -i ${WORKDIR}/glance-api.conf 82 sed 's:^swift_store_user =.*:swift_store_user = ${SERVICE_TENANT_NAME}\:${SRCNAME}:g' -i ${WORKDIR}/glance-api.conf
82 sed 's:^swift_store_key =.*:swift_store_key = ${SERVICE_PASSWORD}:g' -i ${WORKDIR}/glance-api.conf 83 sed 's:^swift_store_key =.*:swift_store_key = ${SERVICE_PASSWORD}:g' -i ${WORKDIR}/glance-api.conf
83 sed 's:^swift_store_create_container_on_put =.*:swift_store_create_container_on_put = True:g' -i ${WORKDIR}/glance-api.conf 84 sed 's:^swift_store_create_container_on_put =.*:swift_store_create_container_on_put = True:g' -i ${WORKDIR}/glance-api.conf