summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-glance_git.bb
diff options
context:
space:
mode:
authorAndy Ning <andy.ning@windriver.com>2014-07-16 11:37:37 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:59 -0400
commit0aec82d70fa032bfe616ea5058d504f860e241f8 (patch)
treecd88ce4f6c7ac88308b85d1ce66941877978cc51 /meta-openstack/recipes-devtools/python/python-glance_git.bb
parentceecd0d46de35111f4c3c1e65176e09cb2117ecb (diff)
downloadmeta-cloud-services-0aec82d70fa032bfe616ea5058d504f860e241f8.tar.gz
Keystone: package service/user additions
Instead of creating tenant/user/role and service/endpoint for all openstack services in keystone postinstall, now each of the services creates its own keystone identities by queueing them up in its postinstall to a file /etc/keystone/service-user-setup. service-user-setup script, when run as the last postinstall, calls identity.sh with keystone identity parameters to create necessary identities for the services. Signed-off-by: Andy Ning <andy.ning@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-glance_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 7aef639..ee8ff09 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -18,7 +18,7 @@ PV="2014.2.b1+git${SRCPV}"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit setuptools update-rc.d identity default_configs 21inherit setuptools update-rc.d identity default_configs hosts
22 22
23GLANCE_DEFAULT_STORE ?= "file" 23GLANCE_DEFAULT_STORE ?= "file"
24GLANCE_KNOWN_STORES ?= "glance.store.rbd.Store,\ 24GLANCE_KNOWN_STORES ?= "glance.store.rbd.Store,\
@@ -28,6 +28,25 @@ GLANCE_KNOWN_STORES ?= "glance.store.rbd.Store,\
28 glance.store.http.Store" 28 glance.store.http.Store"
29 29
30 30
31SERVICECREATE_PACKAGES = "${SRCNAME}-setup"
32KEYSTONE_HOST="${CONTROLLER_IP}"
33
34# USERCREATE_PARAM and SERVICECREATE_PARAM contain the list of parameters to be set.
35# If the flag for a parameter in the list is not set here, the default value will be given to that parameter.
36# Parameters not in the list will be set to empty.
37
38USERCREATE_PARAM_${SRCNAME}-setup = "name pass tenant role email"
39SERVICECREATE_PARAM_${SRCNAME}-setup = "name type description region publicurl adminurl internalurl"
40python () {
41 flags = {'type':'image',\
42 'description':'OpenStack Image Service',\
43 'publicurl':"'http://${KEYSTONE_HOST}:9292/v2'",\
44 'adminurl':"'http://${KEYSTONE_HOST}:9292/v2'",\
45 'internalurl':"'http://${KEYSTONE_HOST}:9292/v2'"}
46
47 d.setVarFlags("SERVICECREATE_PARAM_%s-setup" % d.getVar('SRCNAME',True), flags)
48}
49
31do_install_prepend() { 50do_install_prepend() {
32 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/functional/__init__.py 51 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/functional/__init__.py
33 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/unit/base.py 52 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/unit/base.py